Bright Sparks
NZMaths Home Toni's Tiara Diamonds Nice Dice
Frogs Round Table Six Circles Double Trouble Sole Survivor

Notice for Windows XP Users:


You may find that when you try our Java auto-detection process that you get a message saying that you should download Windows service pack one (which has an updated version of Java included).  This is not required to run Brightsparks applets!  If you get such a message,  you may download the service pack if you desire - but it will take a long time as it is a very large package.  However, if all you want to do is to run the Brightsparks applets then we suggest that you do not download the service pack - simply return to this page and select the option to download Java 1.3.1 (below).


With that in mind, you may start the auto-detection process by clicking here.


If you have returned to this page and require the 1.3.1 version of Java, you can install it directly from the web by clicking here in Internet Explorer and choosing the 'open' option (alternatively, if you know what you are doing or are using another browser, you can save the file to your harddrive and install it later by executing the file)